Forum


Suchen Forum RSS RSS2 SuchenSuchen Mitgliederliste Mitgliederliste RegistrierenRegistrieren ProfilProfil Login


Info: Der Forenbetrieb wurde leider eingestellt.

Gehe zu: » Forum » Allgemeiner Support zu Scripten von PA-S.de » Clicktracker: Update funktioniert nicht...

Seite: 1

Thema
Autor
Clicktracker: Update funktioniert nicht...
Beitrag von xmg21 am: 14.10.2008 10:40:56

Hi,

Wie funktioniert das mit dem Update?

Bei mir kommst nämlich eine Fehlermeldung:

Zitat:
Der Update war fehlerhaft:
Duplicate column name 'LAST'


Ich hab mir die Anleitung in der TXT mal kurz durchgelesen, da steht, dass man alte Dateien mit neuen ersetzen soll, nur woher bekomme ich die neuen Dateien?

Und dann habe ich zwar diese Datei:

update_2_5_zu_2_6.php

Und das neuste Update fehlt da auch:

update_2_6_zu_2_7.php


Über Hilfe würde ich mich freuen.

LG


Dieser Beitrag wurde schon 1x bearbeitet.
Zuletzt am 14.10.2008 10:42:45 von xmg21.


xmg21
Benutzer

Beiträge: 1
OFF PN Schicken
AW: Clicktracker: Update funktioniert nicht...
Beitrag von PAS am: 16.10.2008 13:58:47

Hallo,
lade zunächst einmal das aktuelle Version des Scripts herunter (2.7). [Darin sind die aktuellen Dateien zum ersetzen enthalten]

Nun gehst du wie folgt vor, bei einem Update von 2.5 auf 2.7:

1. Übernehmen Sie die Einstellungen der alten config.inc.php in die neue config.inc.php
2. Fügen Sie in der config.inc.php folgende Variable hinzu:
// Dir ROOT PFAD [Ohne / am Ende] [Richtigen Pfad einstellen!]
$mainpfad = "/srv/www/htdocs/webxy/html/clicktracker";
3. Laden Sie alle Dateien außer installation.php auf ihren Webserver
4. Führen Sie update_2_5_zu_2_6.php aus
5. Löschen Sie nach dem erfolgreichen Update update_2_5_zu_2_6.php

Bei einem Update von 2.6 auf 2.7:
1. Ersetzen sie die Datei admin.php und clicktracker.php mit der neuen Datei
2. Fügen Sie in der config.inc.php folgende Variable hinzu:
// Dir ROOT PFAD [Ohne / am Ende] [Richtigen Pfad einstellen!]
$mainpfad = "/srv/www/htdocs/webxy/html/clicktracker";
3. Laden Sie die Datei phptracker.php hoch
4. Fertig!

Das Update Script (update_2_5_zu_2_6.php) kann nur 1x aufgerufen werden, daher müsste bei dir die Tabellenstruktur schon geändert worden sein. Eine Datei "update_2_6_zu_2_7.php" gibt es nicht, da zwischen den Versionen .6 und .7 keine Änderungen an der Datenbankstruktur vorgenommen worden sind.

Gruss Patrick


Dieser Beitrag wurde schon 1x bearbeitet.
Zuletzt am 16.10.2008 14:00:58 von PAS.


PAS
Administrator


Beiträge: 762
OFF PN Schicken Homepage

Seite: 1



Statistik
Statistik
Es wurden insgesamt 3838 Beiträge geschrieben.
Wir haben 11066 registrierte Mitglieder.
Der neueste Benutzer ist laustralianorth - Forum Beta³ - Bug melden